登陆

根据RIP和OSPF华为设备的网络拓扑

admin 2019-11-01 181人围观 ,发现0个评论

本章首要涉及到RIPv2、OSPF多区域、重分发以及单臂路由的装备指令

拓扑如下:

引荐过程:

  • 依照拓扑图给设备装备相关IP地址
  • SW1创立vlan,将接口参加vlan,交流路由链路装备为trunk
  • R2装备单臂路由,敞开子接口,不同vlan间通讯
  • 路由器R1和R2装备RIPv2,宣告直连网络,装备RIP汇总
  • 装备OSPF多区域,重分发
  • 敞开长途管理功用
  • 桥接PC拜访长途

开端装备:

  • 依照拓扑图给设备装备相关IP地址
1)路由器R1装备IP地址
[R1]int LoopBack 1 #创立loop back 1接口
[R1-LoopBack1]ip add 172.16.1.1 24 #loo1接口装备IP地址
[R1-LoopBack1]quit #保存退出
[R1]int LoopBack 2 #创立loop back 2接口
[R1-LoopBack2]ip add 172.16.2.1 24 #loo2接口装备IP地址
[R1-LoopBack2]quit
[R1]int LoopBack 3 #创立loop back 3接口
[R1-LoopBack3]ip add 172.16.3.1 24 #loo3接口装备IP地址
[R1-LoopBack3]quit
[R1]int LoopBack 4 #创立loop back 4接口
[R1-LoopBack4]ip add 172.16.4.1 24 #loo3接口装备IP地址
[R1-LoopBack4]quit
[R1]int g 0/0/0 #进入G0/0/0接口
[R1-GigabitEthernet0/0/0]ip add 192.168.10.1 24 #装备IP根据RIP和OSPF华为设备的网络拓扑地址
[R1-GigabitEthernet0/0/0]quit
[R1]display ip int b #检查R1接口IP


2)路由器R2装备IP地址
[R2]int LoopBack 1 #创立loop back 1接口
[R2-LoopBack1]ip add 1.1.1.1 32 #loo 1接口装备IP地址
[R2-LoopBack1]quit
[R2]int g 0/0/0 #进入G0/0/根据RIP和OSPF华为设备的网络拓扑0接口
[R2-GigabitEthernet0/0/0]ip add 192.168.10.2 24 #装备IP地址
[R2-GigabitEthernet0/0/0]quit
[R2]int g 0/0/1 #进入G 0/01接口
[R2-GigabitEthernet0/0/1]ip add 192.168.20.1 24 #装备IP地址
[R2-GigabitEthernet0/0/1]quit
[R2]display ip int b #检查R2接口IP


3)路由器R3装备IP地址
[R3]int LoopBack 1 #创立loop back 1接口
[R3-LoopBack1]ip add 2.2.2.2 32 #装备IP地址
[R3-LoopBack1]quit
[R3]int g 0/0/1 #进入G0/0/1接口
[R3-GigabitEthernet0/0/1]ip add 192.168.20.2 24 #装备IP地址
[R3-GigabitEthernet0/0/1]quit
[R3]int g 0/0/0 #进入G0/0/0接口
[R3-GigabitEth根据RIP和OSPF华为设备的网络拓扑ernet0/0/0]ip add 192.168.30.1 24 #装备IP地址
[R3-GigabitEthernet0/0/0]quit
[R3]display ip int b #检查R3接口IP


4)路由器R4装备IP地址
[R4]int LoopBack 1 #创立loop back 1接口
[R根据RIP和OSPF华为设备的网络拓扑4-LoopBack1]ip add 3.3.3.3 32 #装备IP地址
[R4-LoopBack1]quit
[R4]int g 0/0/0 #进入G0/0/0接口
[R4-GigabitEthernet0/0/0]ip add 192.168.30.2 24 #装备IP地址
[R4-GigabitEthernet0/0/0]quit
[R4]int g 0/0/1 #进入G0/0/1接口
[R4-GigabitEthernet0/0/1]ip add 192.168.40.1 24 #装备IP地址
[R4-GigabitEthernet0/0/1]quit
[R4]display ip int b #检查R4接口IP

5)桥接主机和vlan的PC机装备IP以及网关

  • SW1创立vlan,将接口参加vlan,交流路由链路装备为trunk
1)SW1创立v购置税lan10和vlan20
[SW1]vlan batch 10 20 #批量创立vlan
2)将接口参加vlan
[SW1]int eth 0/0/2 #进入0/0/2接口
[SW1-Ethernet0/0/2]port link-ty access #设置为接入链路
[SW1-Ethernet0/0/2]port default vlan 10 #参加vlan10
[SW1-Ethernet0/0/2]quit
[SW1]int eth 0/0/3 #进入0/0/3接口
[SW1-Ethernet0/0/3]port link-type access #设置为接入链路
[SW1-Ethernet0/0/3]port default vlan 20 #参加vlan 20
[SW1-Ethernet0/0/2]quit
[SW1]display vlan #检查接口是否参加vlan


3)将交流机Ethernet0/0/1接口装备为trunk链路
[SW1]int eth 0/0/1 #进入Ethernet0/0/1接口
[SW1-Ethernet0/0/1]port link-type trunk #设置为trunk链路
[SW1-Ethernet0/0/1]port trunk allow-pass vlan all #设置承载一切vlan
[SW1]display vlan #检查trunk链路是否装备成功


  • R2装备单臂路由,敞开子接口,不同vlan间通讯
1)装备子接口
[R2]int GigabitEthernet 0/0/2.10 #创立子接口
[R2-GigabitEthernet0/0/2.10]ip add 192.168.50.254 24 #子接口装备IP地址
[R2-GigabitEthernet0/0/2.10]dot1q termination vid 10 #子接口为vlan 10服务
[R2-GigabitEthernet0/0/2.10]arp broadcast enable #敞开ARP播送
[R2-GigabitEthernet0/0/2.10]quit
[R2]int GigabitEthernet 0/0/2.20 #创立子接口
[R2-GigabitEthernet0/0/2.20]ip add 192.168.60.254 24 #子接口装备IP地址
[R2-GigabitEthernet0/0/2.20]dot1q termination vid 20 #子接口为vlan 10服务
[R2-GigabitEthernet0/0/2.20]arp broadcast enable #敞开ARP播送
[R2-GigabitEthernet0/0/2.20]quit
[R2]displdisplay ip int b #检查子接口是否敞开


  • 验证不同vlan间通讯


  • 路由器R1和R2装备RIPv2,宣告直连网络,装备RIP汇总
1)R1装备RIPv2,宣告直连
[R1]rip 1 #发动rip进程号
[R1-rip-1]version 2 #设置rip版别v2
[R1-rip-1]network 192.168.10.0 #宣告直连网络
[R1-rip-1]network 172.16.0.0 #宣告直连网络
[R1-rip-1]quit
2)R2装备RIPv2,宣告直连
[R2]rip 1 #发动rip进程号
[R2-rip-1]version 2 #设置rip版别v2
[R2-rip-1]network 192.168.10.0 #宣告直连网络
[R2] display ip routing-table protocol rip #检查rip详细信息


3)R1装备路由汇总
[R1]int G0/0/0 #进入G0/0/0接口
[R1-GigabitEthernet0/0/0]rip summary-address 172.16.0.0 255.255.0.0 #装备汇总
[R2] display ip routing-table protocol rip #检查汇总后rip的详细信息


  • 装备OSPF多区域,重分发
1)R2装备OSPF
[R2]ospf 1 router-id 1.1.1.1 #指定OSPF进程号,指定router-id
[R2-ospf-1]area 0 #指定OSPF区域
[R2-ospf-1-area-0.0.0.0]network 1.1.1.1 0.0.0.0 #宣告直连网络,掩码写反码
[R2-ospf-1-area-0.0.0.0]network 192.168.20.0 0.0.0.255 #宣告直连网络
2)R3装备OSPF
[R3]ospf 1 router-id 2.2.2.2 #指定OSPF进程号,指定router-id
[R3-ospf-1]area 0 #指定OSPF区域
[R3-ospf-1-area-0.0.0.0]network 2.2.2.2 0.0.0.0 #宣告直连网络
[R3-ospf-1-area-0.0.0.0]network 192.168.20.0 0.0.0.255 #宣告直连网络
[R3-ospf-1-area-0.0.0.0]quit
[R3-ospf-1]area 1 #指定OSPF区域
[R3-ospf-1-area-0.0.0.1]network 192.168.30.0 0.0.0.255 #宣告直连网络
3)R4装备OSPF
[R4]ospf 1 router-id 3.3.3.3 #指定OSPF进程号,指定router-id
[R4-ospf-1]area 1 #指定OSPF区域
[R4-ospf-1-area-0.0.0.1]network 3.3.3.3 0.0.0.0 #宣告直连网络
[R4-ospf-1-area-0.0.0.1]network 192.168.30.0 0.0.0.255 #宣告直连网络
[R4-ospf-1-area-0.0.0.1]quit
[R4]display ip routing-table protocol ospf #检查OSPF详细信息




4)OSPF重分发到RIP、RIP重分发到OSPF,
[R2]rip 1 #进入rip
[R2-rip-1]import-route ospf 1 cost 1 #将OSPF重分发到rip中
[R2]ospf 1 #进入ospf
[R2-ospf-1]import-route rip 1 cost 1 #将rip重分发到ospf中



5) OSPF重分发直连路由
[R2]ospf 1 #R2进入ospf
[R2-ospf-1]import-route direct type 2 #重分发直连路由
[R4]ospf 1 #R4进入ospf
[R4-ospf-1]import-route direct type 2 #重分发直连路由



  • 敞开长途管理功用
[R1]user-interface vty 0 4 #答应5个终端拜访
[R1-ui-vty0-4]authentication-mode password #验证试验暗码
[R1-ui-vty0-4]set authentication password cipher pwd@123 #装备密文暗码pwd@123
[R1根据RIP和OSPF华为设备的网络拓扑-ui根据RIP和OSPF华为设备的网络拓扑-vty0-4]user privilege level 15 #装备管理权限
[R1-ui-vty0-4]quit
  • 桥接PC拜访长途


请关注微信公众号
微信二维码
不容错过
Powered By Z-BlogPHP